Translate Ideas and Comments
Choose language:
There was an error during translation

Settings and activity

  1. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  2. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Planned  ·  1 comment  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  3. 7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn supported this idea  · 
  4. 5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Developers » API  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn supported this idea  · 
  5. 14 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Soaryn commented  · 

    Adding on to what Barry said, I don't recommend using a boolean flag for this. There was a string identifier in pubsub, while I'd like it to just have Prime, Tier1, Tier2, etc, remaining consistent to the platform would be more idealistic, so it'd likely be Prime, 1000, 2000, so on.

  6. 37 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Soaryn commented  · 

    There are some notes to make. Example: someone gifting community subs. In pubsub currently it should be noted there is no way to link multiple gifts provided at once from one person, you have to guess. Something to rectify this would be to have a 'payload_id' and 'payload_count' added to each sub event.
    This way if someone subs, the payload_id would be unique and payload_count would be 1.
    If someone gifted multiple subs in one burst (the community giftsub) then the payload_id would match to all of those related subs, and the payload_count would be the number of subs gifted in that burst.

    Soaryn supported this idea  · 
  7. 13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn supported this idea  · 
  8. 6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  9. 10 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  10. 7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  11. 11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn shared this idea  · 
  12. 6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn supported this idea  · 
  13. 44 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Developers » EventSub  ·  Flag idea as inappropriate…  ·  Admin →
    Soaryn supported this idea  · 
  14. 4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Investigating  ·  2 comments  ·  Developers  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Soaryn commented  · 

    Marenthyu pointed out some changes as well as answered some questions on use cases for some of the fields.
    ==Redemption Info:==
    Time String
    Id GUID (String)
    Channel User
    Redeemer User
    UserInput String
    Status String
    Reward RewardInfo

    ==Fields of Reward:==
    Id GUID (String)
    Name String
    Prompt String
    Cost Integer
    InputRequired Boolean
    SubOnly Boolean
    TotalUsed Integer
    MaxLimit Integer

    An error occurred while saving the comment
    Soaryn commented  · 

    Old Data:
    "type" - Unnecessary. This is encoded into the topic already one layer up. If you want this can be changed to context.
    "data": - No reason to encapsulate further
    "timestamp": - should just be named "time" to be consistent with other topics
    "redemption": - Unnecessary encapsulation
    "id": - should be on root.
    "user": - Fine actually.
    "channel_id": - Should match the user structure so you are presented with username and displayname as well.
    "redeemed_at": - Should just be time. I understand there is a difference when the message was created and when a reward was redeemed. But we shouldn't need to know message creation
    "reward": {
    "id": - This is fine to have separate from "root/id"
    "channel_id": - Unnecessary. We already have the channel this is associated to.
    "title": - Fine
    "prompt": - Fine
    "cost": - Fine
    "is_user_input_required": - Will we get an event at all before they input? "input_required" would be a better name
    "is_sub_only": - Can remain
    "max_per_stream": { "is_enabled": false, "max_per_stream": 0 } - perhaps too verbose,
    "user_input": "yeooo",
    }
    Unnecessary Data static data. Provide an API fetch instead.:
    "image" - Example on document has 147 byte per url for just image.
    "default_image"
    "background_color" - Why?

    How do we even get the event if they are toggled?
    "is_enabled": true,
    "is_paused": false,
    "is_in_stock": true,

    "should_redemptions_skip_request_queue": - what?
    "status": - Does this have other options?

    Soaryn shared this idea  ·