Skip to content
Translate Ideas and Comments
Choose language:
There was an error during translation

Video Features

How it works:
  • Choose a relevant category for your idea and check to see if any other users have already submitted this suggestion before creating your own
  • Be clear with your suggestion, provide examples and solutions to the problem you are posing. Suggestions without actionable feedback may be closed without comment
  • Upvote existing ideas, as opposed to creating multiple similar requests
  • Be sure to share your suggestion with others to gain more support!
  • Note: Suggestions are not guarantees that we will take action on an idea. We will try our best to communicate why an idea may not work, but may not always be able to share that information.
  • Titles that are unclear or unnecessarily vulgar may be reworded to better reflect the request for ease of discovery


If you need help:
This forum is for ideas only. If you need help, please check out our help portal for tons of articles that may answer your questions. If you still need help, you can reach out to our support team in the help portal as well!

Appeals or commentary on suspension decisions, support requests, suggestions disparaging others, and non-constructive feedback will be closed without comment.




Video Features

Categories

JUMP TO ANOTHER FORUM

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback

75 results found

  1. Jeres clipmaker, vil kun poste 30 sekunders klip - Når jeg vil lave et klip, så står der:"Øv, noget gik galt.". Jeg har forsøgt op til flere gange, og det vil ikke virke, som det skal. Det er fra den her VOD, at jeg har forsøgt at lave klip fra: https://www.twitch.tv/videos/1727099503

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. There seems to be a very noticeable audio glitch at the end of Highlight Segments. The audio cuts off for a very quick moment. All of my Highlights have this issue. This issue occurs even for each Segment when there are multiple Segments in a Highlight. Please fix, thank you.

    Here is an example video on Twitch and YouTube. The glitch is at the 0:36 mark:

    https://www.twitch.tv/videos/1696249008
    https://www.twitch.tv/videos/1696249008?t=00h00m36s

    https://youtu.be/ny6RktzflWQ
    https://youtu.be/ny6RktzflWQ?t=36

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Sometimes, when I come back to edit a clip I have made during stream, the clip video will not properly load, and the seek bar will show -30 at the timestamp. You will not be able to seek to any other time in the video.

    You also have to refresh the page over and over again in the hopes for it to eventually work. (Which increases view counts for some reason too FYI )

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. I just got done streaming for over 5 hours, but after raiding someone and stopping stream, the VOD was only 6 minutes 17 seconds, why ? and can we fix this ?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. I am trying to download my VOD stream which is a 1-hour long stream but I download it and the file is slowed and stretched to 5 hours and it doesn't show the video. I cannot use the video for iMovie/movie maker and saving the file takes 20+ hours. This has never happened, my downloads should not be stretched and slowed. Please fix.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Twitch, please stop automatically muting the last 2 seconds of each clip in the highlight tool. This is absurd, I have to make all clips longer so the audio isn't cut off at the end of the important part of the clip that I'm making, which makes the clips very awkward by ending with an extra section of unimportant content.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. When a streamer outputs their broadcast in 21:9 aspect ratio (3440x1440, 2560x1080etc) the thumbnail for the stream is stretched vertically to compensate for the thumbnail's forced 16:9 scale.

    A bug fix that automatically adds black bars horizontally across the top & bottom on thumbnails the same as twitch automatically does for the stream itself would be beneficial and not cause viewers to be mislead on someone's overall channel quality.

    Here's an example of the issue and a fix:
    https://gyazo.com/c50462eb268da19d2707f4aa0fd69475

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Priority: p3
    Severity: s3
    Description: Logged user volume button not working properly
    Steps: 1: Open stream channel and mute steam volume.
    2: Reload the page.
    3: Click on volume mute button.
    Expected result: When clicking volume mute button to mute and unmute volume.
    Actual result: When clicking volume mute button nothing happens.
    Component: Streamer channel livestream
    Environment: Google Chrome Version: 106.0.5249.120
    Date: 27.10.2022

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. As an avid clipper in the community I'm in (I've made over 400 clips this year alone), there are a couple of absolutely infuriating bugs I've been dealing with for several years now.

    The first issue is a bug where the first 60 seconds of video of the 90 seconds of captured, editable clip footage will completely disappear, and you'll be stuck with only the most recent 30 seconds. This presents itself in a strange way on the clip page, though. The in-video scroller counts the most recent 30 seconds of video captured as the first 30 seconds of the…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. When a bottom of player ad is loaded it makes selecting the source setting unusable as the options are covered by the ad on the oprea gx browser havent checked others

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. When hovering the clip or theater mode buttons on macOS it says the keyboard shortcuts use alt (alt+x, alt+t) when they actually use option (option+x, option+t).

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. This is more item for a developer team but it impacts my personal experience.

    When I watch streams on my Mac in Safari or any other browser, it shows a time on touch-bar that seems to overload my laptop and it literally starts boiling and dying extra fast (probably due to calculation.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Recently tried to make ~15-20 minutes of highlights from 2 different vods. After creating all of the segments and publishing, the highlight that published started at some random timestamp from the first VOD for about 6-7 minutes then went into the segments from the first VOD, the second VOD's segments weren't included. I tried the same thing over again and it happened exactly the same.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. everytime i edit my videos on highlights and post it, some of the video clips is missing and just jump to the end. Please fix this thank you twitch developers

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. The Picture-in-Picture button does not work if I'm sent from one stream to another (being a raider).

    For example:
    If the query ?referrer=raid is included in the URL and I click on the Picture-in-Picture mode nothing happens. If I remove the query, go to the URL, and click on the Picture-in-Picture button everything works as expected.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. I click on a previous broadcast (I can hear it) and select the Highlight button. There is no audio during playback. I can't hear a thing.

    BUT, if I create a highlight anyway, there is sound on the highlighted video.
    This bug started about a week ago.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Problem: When you are watching the VOD and your internet gets disconnected (error #2000) the VOD player gives you a button "Click here to reload the player"
    (note: the player has to finish playing the buffered content before throwing the error)

    Expected result: after establishing internet connection user is pressing the button and continues watching the VOD in the same spot (or at least close to) where he lost connection
    Actual result: after establishing internet connection user is pressing the button and VOD starts playing from the beginning.

    This gets extremely annoying when you watch 10 hour VODs and have…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. There is a conflict when registering a click between the Collection overlay during VOD playback and the video progress bar for collections with over 6 videos. While the collection UI is visible I would expect to be able to click on one of the thumbnails to load a different VOD, but the final video cannot be clicked because it sits at the same level as the VOD progress bar, which takes click precedence and will skip the video to that position instead.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. I'm referring to the small preview images you see while moving your mouse over a VOD's time bar. When I open a VOD page, these previews work as expected. But after a Twitch ad plays on the VOD, it breaks and there are no more preview thumbnails. Refreshing the page fixes the issue, until the next ad plays.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. I'm not sure if this is where I'm supposed to post this or not, but my VOD is not loading and displaying "Error 2000" each time I try. I've tried restarting, using differnet devices, and logging out/in. The video will still not play. It also won't export or download. What has happened and how can I view/export/download this this video? Link below.

    https://www.twitch.tv/videos/1411214269

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
← Previous 1 3 4
  • Don't see your idea?