How can we improve game mods and CurseForge?

Update the "Support Game Versions" dropdown for addons

When creating a new addon project, the drop-down menu used to specify the game version the add-on supports only has Minecraft 1.7 and below. The game is currently on 1.12 (which is in beta but is the most active version for add-ons)

3 votes
Sign in Sign in with OpenID Connect
Signed in as (Sign out)

We’ll send you updates on this idea

TooGoodMules shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
under review  ·  Adminhubglacier (Product Manager, Twitch) responded  · 

Hello, and thank you for taking the time to submit your idea! We are looking into this suggestion internally and will update this page once a final decision has been made. Please add any additional details that you think would be helpful in the comments!

1 comment

Sign in Sign in with OpenID Connect
Signed in as (Sign out)
Submitting...
  • TooGoodMules commented  ·   ·  Flag as inappropriate

    Any update on this? It really shouldn't take a dev longer than 5 mins to hotfix a few version numbers into a select. It's been over 2 weeks.

Feedback and Knowledge Base