How can we improve game mods and CurseForge?

A working REFRESH button would be nice

Currently, clicking the REFRESH button does nothing. The button is not animated in any way to show it is doing anything, and if it does, that is nothing.

I have to actually EXIT the program, launch it again to find new mods that have updates.

eg: I had 2 mods that showed updates available.
Hit refresh, still 2 mods. Hit refresh, still 2 mods.
QUIT PROGRAM and start it again, now shows FIVE (5) mods that have updates.

OLD version worked beautifully. You could click 'refresh' and it worked. You could keep things sorted that mods which have updates are always up at the top, etc.

Please fix. Having to quit and restart is not a solution to a broken button.

5 votes
Sign in Sign in with OpenID Connect
Signed in as (Sign out)

We’ll send you updates on this idea

Mark shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
under review  ·  Adminhubglacier (Product Manager, Twitch) responded  · 

Hello, and thank you for taking the time to submit your idea! We are looking into this suggestion internally and will update this page once a final decision has been made. Please add any additional details that you think would be helpful in the comments!

1 comment

Sign in Sign in with OpenID Connect
Signed in as (Sign out)
Submitting...
  • X_Niter commented  ·   ·  Flag as inappropriate

    For the last while the updating modpacks in the minecraft area has been having issues for many of my pack members. Any possibility in looking to see why the update button has stopped showing up when modpacks are updated. It has taken days for even being able to see the button show up. Is there any way to also have the updates show up faster and fix the issue of it not showing up? To explain more in detail, When i have my pack update approved i have had to wait 3 hours too multiple days before i saw the ability to update the pack in the Twitch desktop application, alongside with that i have gotten a lot of word back from my members that say that they go without seeing the update for more than a week, which results in them having to manually download it from the website then manually import it causing them to lose a lot of saved data they did want to lose. As this is calling for more of letting y'all know that there is a lot of bugging things happening with the minecraft modpack updates. From taking a long time to show up after it's approved to not showing up at all and having to manually install it causing loss of data and saved information.

Feedback and Knowledge Base